博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
April Fools Day Contest 2016 G. You're a Professional
阅读量:6757 次
发布时间:2019-06-26

本文共 1232 字,大约阅读时间需要 4 分钟。

G. You're a Professional

题目连接:

Description

A simple recommendation system would recommend a user things liked by a certain number of their friends. In this problem you will implement part of such a system.

You are given user's friends' opinions about a list of items. You are also given a threshold T — the minimal number of "likes" necessary for an item to be recommended to the user.

Output the number of items in the list liked by at least T of user's friends.

Input

The first line of the input will contain three space-separated integers: the number of friends F (1 ≤ F ≤ 10), the number of items I (1 ≤ I ≤ 10) and the threshold T (1 ≤ T ≤ F).

The following F lines of input contain user's friends' opinions. j-th character of i-th line is 'Y' if i-th friend likes j-th item, and 'N' otherwise.

Output

Output an integer — the number of items liked by at least T of user's friends.

Sample Input

3 3 2

YYY
NNN
YNY

Sample Output

2

Hint

题意

有m个人,有n个人给他Y或者N,如果大于等于T个人的话,这个人就很厉害。

问你有多少个人很厉害。

题解:

水题,但是特别迷……

你第一发肯定是wa的,然后第二发得和第一发的语言不一样

交上去之后发现代码长度过长了,然后缩代码

然后发现要加一个kitten

然后就ac了

代码

f,I,T=map(int,input().split())s=[];for i in range(f):    s.append(input())print(sum(sum((s[i][j] == 'Y' for i in range(f)))>=T for j in range(I)))#kitten

转载地址:http://ssweo.baihongyu.com/

你可能感兴趣的文章
陶哲轩实分析 习题 7.1.5
查看>>
团队项目—后续阶段第三天
查看>>
python中的gil是什么?
查看>>
BFS 2015百度之星初赛2 HDOJ 5254 棋盘占领
查看>>
黑马程序员 ——ios点语法和类的三大特性
查看>>
Redis数据库总结
查看>>
python 阿狸的进阶之路(8)
查看>>
C#.net地址传参汉字乱码解决方案
查看>>
20155229《网络对抗技术》Exp:网络欺诈防范
查看>>
【本周面试题】第3周 - 浏览器相关面试题
查看>>
Struts13---Ognl
查看>>
11 Best CSS Frameworks For Making Your Website Stylish
查看>>
原型——设计思维之建立模型
查看>>
centos 7.2 同步北京时间 ,多台机器同步时间
查看>>
centos 7 设置开机启动脚本
查看>>
网络之 Iptables总结
查看>>
oracle之 安装 11G RAC 报 NTP failed
查看>>
Centos6.5环境下安装redis单机版以及Jedis连接
查看>>
『004』索引-Python
查看>>
常用的正则表达式(方便自己看)
查看>>